Versión mínima de PHP

Desde hace unas pocas versiones de WordPress, todos aquellos desarrolladores de plugins pueden indicar la versión mínima de PHP necesaria para que funcione. WordPress está poniendo muchos esfuerzos en mantener al día y con unas versiones actualizadas todos sus productos y servicios, y eso implica a los propios desarrolladores, tal y como se informó en agosto de 2017.

La idea es que en la cabecera del plugin se indique con una línea la versión mínima:

=== Plugin Name ===
Contributors: (this should be a list of wordpress.org userid's)
Donate link: http://example.com/
Tags: comments, spam
Requires at least: 4.6
Tested up to: 4.8
Requires PHP: 5.6
Stable tag: 4.3
License: GPLv2 or later
License URI: https://www.gnu.org/licenses/gpl-2.0.html

En este caso, se indica el texto Requires PHP: 5.6 en el que se informa que la versión mínima de funcionamiento del plugin es 5.6; por lo tanto, aquellos usuarios que tengan versiones anteriores de PHP en su sistema recibirán un aviso conforme puede no funcionar o directamente bloquear la posible instalación.

En el repositorio de plugins, además, aparecerá un aviso de la versión en la zona de información técnica.

Deja un comentario