PHP

Si WordPress tiene un punto importante es el de PHP, y esto es lo que más se está potenciando últimamente (por no decir casi desde siempre). Y es por esto que muchos de los proyectos internos que se están desarrollando alrededor de WordPress como Project Tide o Servehappy.

Ocultar la versión

Sin duda lo primero que hemos de hacer es ocultar la versión de PHP para que no sea pública desde las peticiones del servidor web. Para ello, deberemos configurar el fichero [php.ini] para que la línea de visualización de la versión no aparezca.

expose_php = Off

Ocultar los errores

De la misma manera que ocultamos la versión de PHP, también deberemos asegurarnos que no mostramos posibles errores de ejecución del propio PHP. Esto puede generar la “pantalla blanca de la muerte” debido a que si algo falla, no podremos ver nada y en caso de necesitarlo, se deberán activar las herramientas que el propio WordPress trae para hacer debug.

display_errors = Off

Compatibilidad PHP

Tanto si eres desarrollador como simplemente usuario, has de estar encima de qué versión usar de PHP. Es por esto que es muy recomendable usar como versión mínima la versión 7.0, aunque como versión recomendada la versión 7.2. A partir de aquí ¿cómo saber si los plugins o plantillas que tienes son compatibles con las versiones recomendadas? Pues para ello lo mejor es utilizar el plugin WP Compatibility Checker.

Con este plugin obtendrás de forma resumida si los plugins son compatibles, y si no lo son, qué deberían de mejorarse o cambiarse. Al instalarlo vas a poder elegir qué versión analizar y sus resultados.

WP-CLI

Además, un detalle muy interesante es que se puede hacer este análisis de todos los plugins / plantillas o de sólo los activos vía WP-CLI.

wp phpcompat <version> [--scan=<scan>]

<version>
  PHP version to test.

[--scan=<scan>]
  Whether to scan only active plugins and themes or all of them.
  default: active
  options:
    - active
    - all

Integración con Plugins

En los últimos tiempos WordPress ha añadido un campo que indica la versión mínima de PHP necesaria para que funcionen algunos elementos (por ejemplo, los plugins).

=== Plugin Name ===
Contributors: (this should be a list of wordpress.org userid’s)
Donate link: http://example.com/
Tags: comments, spam
Requires at least: 4.6
Tested up to: 4.8
Requires PHP: 5.6
Stable tag: 4.3
License: GPLv2 or later
License URI: https://www.gnu.org/licenses/gpl-2.0.html

Deja un comentario