Versiones

¿Cuáles son las versiones mínimas requeridas para que WordPress funcione correctamente? En principio WordPress funciona con MySQL, PHP y un servidor web, lo que deja un margen muy amplio para funciona, aunque las configuraciones más habituales son la de Linux, nginx o Apache, MySQL y PHP.

Sistema Operativo

En cuanto a sistemas operativos WordPress funciona en cualquier plataforma que soporte el resto de software necesario (base de datos y lenguaje de programación). Los sistemas operativos más habituales son CentOS y Ubuntu. En el caso de elegir este último, lo más recomendable es usar una versión LTS (Long Term Support) (con soporte de larga duración) de forma que durante varios años no tendrás que preocuparte de incompatibilidades. Una lista de versiones mínimas recomendadas es:

Sistema OperativoVersión
CentOS7.4
Debian9.3
Fedora27
FreeBSD11.1 ZFS
Ubuntu16.04 LTS

Esta tabla está generada con fecha 2018-01-19

En cualquier caso, hay que utilizar siempre sistema operativos compatibles con 64bits (todos los anteriores le dan soporte) aunque dependerá mucho de la infraestructura de servidores que se vaya a utilizar.

Servidor Web

En cuanto a servidores web, existen varios aunque los más conocidos son Apache HTTPD y nginx. Ambos tienen mucha documentación de configuraciones para WordPress y son los que más compatibilidad disponen. Una lista de versiones mínimas recomendadas es:

Servidor WebVersión
Apache HTTPD2.4
nginx1.12

Esta tabla está generada con fecha 2018-01-19

Base de Datos

A la hora de trabajar con bases de datos podemos disponer de muchas configuraciones. Por norma general trabajaremos en un sistema monolítico (no distribuido) aunque se puede escalar la base de datos de la manera que sea necesaria. En este caso será algo transparente para WordPress por lo que la decisión de la escalabilidad será del administrador de sistemas.

Aunque existen diferencias entre las distintas distribuciones de bases de datos, en general para WordPress es bastante indiferente trabajar con unas u otras. Una lista de versiones mínimas recomendadas es:

Base de DatosVersión
MariaDB Server10.2
MySQL Community Server5.7
Percona Server for MySQL5.7

Esta tabla está generada con fecha 2018-01-19

PHP

Uno de los puntos donde WordPress tiene mucho recorrido es el PHP y es que históricamente se ha sido muy flexible con el uso de este lenguaje y su compatibilidad con versiones anteriores, pero por el lanzamiento de nuevas versiones y con grandes mejoras en la encriptación y seguridad, lo más recomendable es usar la última versión estable de PHP.

Lenguaje de ProgramaciónVersión
PHP7.2

Esta tabla está generada con fecha 2018-01-19

Aún siendo recomendable la versión 7.2, sí que es cierto que por la novedad en su lanzamiento aún no está disponible al 100% en todos los sistemas operativos, por lo que sí que es recomendable usar al menos la versión 7.0 o 7.1. Versiones 5.x ya han dejado de ser recomendables, principalmente por el empeoramiento en el rendimiento y la velocidad de compilación.

HTTPS

Obviamente, WordPress funciona vía web, y por tanto funciona sobre HTTP, pero hoy en día es básico disponer de un sitio con HTTPS (Hypertext Transfer Protocol Secure) y esto implica utilizar un certificado de encriptación. En este caso si nos ceñimos a temas de seguridad concretos la única opción es la de usar un certificado TLS 1.2. Para ello puedes comprar certificados de cualquier tipo, o utilizar los certificados de Let’s Encrypt.

Certificado de EncriptaciónVersión
TLS1.2

Esta tabla está generada con fecha 2018-01-19

En la página de WordPress tienes unos requerimientos mínimos necesarios para funcionar correctamente.

Deja un comentario